ia64/xen-unstable

changeset 18247:e8839d6028cc

stubdom: Fix the Makefile to avoid brace expansion

While building stubdom, I saw an error.

install: cannot stat `lib/{config,header,pci,types}.h': No such file
or directory

It seems brace expansion is not available in some environments, so we
had better avoid using it.

Signed-off-by: Yosuke Iwamatsu <y-iwamatsu@ab.jp.nec.com>
author Keir Fraser <keir.fraser@citrix.com>
date Mon Aug 04 11:15:24 2008 +0100 (2008-08-04)
parents 404571b0b169
children a1d07389119b
files stubdom/Makefile
line diff
     1.1 --- a/stubdom/Makefile	Mon Aug 04 11:13:27 2008 +0100
     1.2 +++ b/stubdom/Makefile	Mon Aug 04 11:15:24 2008 +0100
     1.3 @@ -132,7 +132,7 @@ cross-libpci: $(LIBPCI_STAMPFILE)
     1.4  	  $(MAKE) CC="$(CC) $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -I$(realpath $(MINI_OS)/include)" lib/libpci.a && \
     1.5  	  $(INSTALL_DATA) lib/libpci.a $(CROSS_PREFIX)/$(GNU_TARGET_ARCH)-xen-elf/lib/ && \
     1.6  	  $(INSTALL_DIR) $(CROSS_PREFIX)/$(GNU_TARGET_ARCH)-xen-elf/include/pci && \
     1.7 -	  $(INSTALL_DATA) lib/{config,header,pci,types}.h $(CROSS_PREFIX)/$(GNU_TARGET_ARCH)-xen-elf/include/pci/ \
     1.8 +	  $(INSTALL_DATA) lib/config.h lib/header.h lib/pci.h lib/types.h $(CROSS_PREFIX)/$(GNU_TARGET_ARCH)-xen-elf/include/pci/ \
     1.9  	)
    1.10  
    1.11  ######