ia64/xen-unstable

view tools/xenctl/setup.py @ 1372:5a6113c65ead

bitkeeper revision 1.891.1.12 (40a248b0WTGoOa9206iWkyGN0mTPNw)

Allow forcing of IRQ trigger-type to edge or level
(NB. DANGEROUS!).
author kaf24@scramble.cl.cam.ac.uk
date Wed May 12 15:54:24 2004 +0000 (2004-05-12)
parents 17430e51466a
children 1d69c0528a2e 138c55619f27 2c6f86e0083e
line source
2 from distutils.core import setup, Extension
3 import sys
5 modules = [ 'xenctl.console_client', 'xenctl.utils' ]
7 # We need the 'tempfile' module from Python 2.3. We install this ourselves
8 # if the installed Python is older than 2.3.
9 major = sys.version_info[0]
10 minor = sys.version_info[1]
11 if major == 2 and minor < 3:
12 modules.append('xenctl.tempfile')
14 setup(name = 'xenctl',
15 version = '1.0',
16 py_modules = modules,
17 package_dir = { 'xenctl' : 'lib' },
18 )