ia64/xen-unstable

changeset 19077:ced1c3069ada

bump libxenctrl and libxenguest versions

In c/s 19009 an incompatible change was made to the ABI of libelf-*,
which are included in libxenctrl and libxenguest. To avoid client
programs (such as python/lowlevel/xc/xc.so) picking up a wrong
version and perhaps crashing, the soname should be changed.

I have chosen the version number 3.4 as xen-unstable is currently the
pre-3.4 branch. I assume we don't care about API/ABI stability within
an unstable branch.

Signed-off-by: Ian Jackson <ian.jackson@eu.citrix.com>
author Keir Fraser <keir.fraser@citrix.com>
date Fri Jan 23 11:51:43 2009 +0000 (2009-01-23)
parents 9b0289a165eb
children 8de0aae803e0
files tools/libxc/Makefile
line diff
     1.1 --- a/tools/libxc/Makefile	Thu Jan 22 18:00:48 2009 +0000
     1.2 +++ b/tools/libxc/Makefile	Fri Jan 23 11:51:43 2009 +0000
     1.3 @@ -1,7 +1,7 @@
     1.4  XEN_ROOT = ../..
     1.5  include $(XEN_ROOT)/tools/Rules.mk
     1.6  
     1.7 -MAJOR    = 3.2
     1.8 +MAJOR    = 3.4
     1.9  MINOR    = 0
    1.10  
    1.11  CTRL_SRCS-y       :=