ia64/xen-unstable

changeset 9784:909664b50602

This fixes a path problem with the current ACM scripts.

Signed-off-by: Stefan Berger <stefanb@us.ibm.com>
author emellor@leeni.uk.xensource.com
date Wed Apr 19 22:52:34 2006 +0100 (2006-04-19)
parents 4ce84cc55727
children 5b1e10215e38
files tools/security/labelfuncs.sh tools/security/updategrub.sh
line diff
     1.1 --- a/tools/security/labelfuncs.sh	Wed Apr 19 22:28:22 2006 +0100
     1.2 +++ b/tools/security/labelfuncs.sh	Wed Apr 19 22:52:34 2006 +0100
     1.3 @@ -147,23 +147,23 @@ findGrubConf()
     1.4  # will hold a pattern
     1.5  # Parameters:
     1.6  # 1st: the path to reach the root directory of the XEN build tree
     1.7 -#      where linux-*-xen0 is located at
     1.8 +#      where linux-*-xen is located at
     1.9  # Results:
    1.10  # The variable linux holds then name and version of the compiled
    1.11 -# kernel, i.e., 'vmlinuz-2.6.12-xen0'
    1.12 +# kernel, i.e., 'vmlinuz-2.6.12-xen'
    1.13  getLinuxVersion ()
    1.14  {
    1.15  	local path
    1.16  	local versionfile
    1.17  	local lnx
    1.18  	if [ "$1" == "" ]; then
    1.19 -		path="/lib/modules/*-xen0"
    1.20 +		path="/lib/modules/*-xen"
    1.21  	else
    1.22  		path="/lib/modules/$1"
    1.23  	fi
    1.24  
    1.25  	linux=""
    1.26 -	for f in $path/linux-*-xen0 ; do
    1.27 +	for f in $path ; do
    1.28  		versionfile=$f/build/include/linux/version.h
    1.29  		if [ -r $versionfile ]; then
    1.30  			lnx=`cat $versionfile | \
    1.31 @@ -178,7 +178,7 @@ getLinuxVersion ()
    1.32  			                 numbers[2],           \
    1.33  			                 numbers[3]);          \
    1.34  			       } else {                        \
    1.35 -			         printf("%s.%s.%s[.0-9]*-xen0",\
    1.36 +			         printf("%s.%s.%s[.0-9]*-xen", \
    1.37  			                numbers[1],            \
    1.38  			                numbers[2],            \
    1.39  			                numbers[3]);           \
    1.40 @@ -192,7 +192,7 @@ getLinuxVersion ()
    1.41  	done
    1.42  
    1.43  	#Last resort.
    1.44 -	linux="vmlinuz-2.[45678].[0-9]*[.0-9]*-xen0$"
    1.45 +	linux="vmlinuz-2.[45678].[0-9]*[.0-9]*-xen$"
    1.46  }
    1.47  
    1.48  
     2.1 --- a/tools/security/updategrub.sh	Wed Apr 19 22:28:22 2006 +0100
     2.2 +++ b/tools/security/updategrub.sh	Wed Apr 19 22:52:34 2006 +0100
     2.3 @@ -41,8 +41,8 @@ Usage: $prg [-d <policies root>] <policy
     2.4                     default is $acmroot
     2.5  <policy name>    : The name of the policy, i.e. xen_null
     2.6  <kernel version> : The version of the kernel to apply the policy
     2.7 -                   against, i.e. 2.6.12.6-xen0
     2.8 -                   If not specified, a kernel version ending with '-xen0'
     2.9 +                   against, i.e. 2.6.16-xen
    2.10 +                   If not specified, a kernel version ending with '-xen'
    2.11                     will be searched for in '/lib/modules'
    2.12  "
    2.13  }