ia64/xen-unstable

changeset 19249:5255784eb0d7

hvmloader: Make build fail if packages required to build hvmloader not present

Also, corrected the message generated by the makefile which says what
packages are required.

Signed-off-by: Alex Zeffertt <alex.zeffertt@eu.citrix.com>
Acked-by: Ian Jackson <ian.jackson@eu.citrix.com>
author Keir Fraser <keir.fraser@citrix.com>
date Mon Mar 02 10:30:15 2009 +0000 (2009-03-02)
parents 9bc5799566be
children 6f207d1eee5c
files tools/firmware/Makefile
line diff
     1.1 --- a/tools/firmware/Makefile	Mon Mar 02 10:26:37 2009 +0000
     1.2 +++ b/tools/firmware/Makefile	Mon Mar 02 10:30:15 2009 +0000
     1.3 @@ -15,13 +15,13 @@ SUBDIRS += hvmloader
     1.4  .PHONY: all
     1.5  all:
     1.6  	@set -e; if [ $$((`( bcc -v 2>&1 | grep version || echo 0.0.0 ) | cut -d' ' -f 3 | awk -F. '{ printf "0x%02x%02x%02x", $$1, $$2, $$3}'`)) -lt $$((0x00100e)) ] ; then \
     1.7 -	echo "==========================================================="; \
     1.8 -	echo "Require dev86 package version >= 0.16.14 to build firmware!"; \
     1.9 -	echo "(visit http://www.cix.co.uk/~mayday for more information)"; \
    1.10 -	echo "==========================================================="; \
    1.11 -	else \
    1.12 +	echo "==========================================================================="; \
    1.13 +	echo "Require dev86 rpm or bin86 & bcc debs version >= 0.16.14 to build firmware!"; \
    1.14 +	echo "(visit http://www.debath.co.uk/dev86/ for more information)"; \
    1.15 +	echo "==========================================================================="; \
    1.16 +	false ; \
    1.17 +	fi
    1.18  	$(MAKE) subdirs-$@; \
    1.19 -	fi
    1.20  
    1.21  
    1.22  .PHONY: install