ia64/xen-unstable

changeset 14400:517e67f0fe52

hvm: Firmware build requires dev86 (bcc) >= 0.16.14.
Earlier versions (at least 0.16.0) generate incorrect code.
Signed-off-by: Keir Fraser <keir@xensource.com>
author kfraser@localhost.localdomain
date Wed Mar 14 19:35:26 2007 +0000 (2007-03-14)
parents 01e35a77ce8f
children 817647aff01f
files tools/firmware/Makefile
line diff
     1.1 --- a/tools/firmware/Makefile	Tue Mar 13 22:13:40 2007 +0000
     1.2 +++ b/tools/firmware/Makefile	Wed Mar 14 19:35:26 2007 +0000
     1.3 @@ -14,10 +14,10 @@ SUBDIRS += hvmloader
     1.4  
     1.5  .PHONY: all
     1.6  all:
     1.7 -	@set -e; if ! `which bcc 1>/dev/null 2>/dev/null`; then \
     1.8 +	@set -e; if [ $$((`bcc -v 2>&1 | grep version | cut -d' ' -f 3 | awk -F. '{ printf "0x%02x%02x%02x", $$1, $$2, $$3}'`)) -lt $$((0x00100e)) ] ; then \
     1.9  	echo "***********************************************************"; \
    1.10 -	echo "WARNING: Install dev86 package to build firmware!"; \
    1.11 -	echo "         (http://www.cix.co.uk/~mayday)"; \
    1.12 +	echo "Require dev86 package version >= 0.16.14 to build firmware!"; \
    1.13 +	echo "(visit http://www.cix.co.uk/~mayday for more information)"; \
    1.14  	echo "***********************************************************"; \
    1.15  	else \
    1.16  	for subdir in $(SUBDIRS); do \