ia64/xen-unstable

changeset 7480:3951b5b01cfd

Two patches were applied to pygrub's setup.py to work around python2.2
limitations and only one is needed. Revert one of them.

Signed-Off-By: Muli Ben-Yehuda <mulix@mulix.org>
author kaf24@firebug.cl.cam.ac.uk
date Sat Oct 22 07:35:36 2005 +0100 (2005-10-22)
parents 21a211649fe2
children 37050ba0e35c
files tools/pygrub/setup.py
line diff
     1.1 --- a/tools/pygrub/setup.py	Fri Oct 21 20:07:54 2005 +0100
     1.2 +++ b/tools/pygrub/setup.py	Sat Oct 22 07:35:36 2005 +0100
     1.3 @@ -12,14 +12,11 @@ if os.path.exists("/usr/include/ext2fs/e
     1.4      ext2defines = []
     1.5      cc = new_compiler()
     1.6      cc.add_library("ext2fs")
     1.7 -    try:
     1.8 -        if hasattr(cc, "has_function") and cc.has_function("ext2fs_open2"):
     1.9 -            ext2defines.append( ("HAVE_EXT2FS_OPEN2", None) )
    1.10 -        else:
    1.11 -            sys.stderr.write("WARNING: older version of e2fsprogs installed, not building full\n")
    1.12 -            sys.stderr.write("         disk support for ext2.\n")
    1.13 -    except AttributeError:
    1.14 -        pass
    1.15 +    if hasattr(cc, "has_function") and cc.has_function("ext2fs_open2"):
    1.16 +        ext2defines.append( ("HAVE_EXT2FS_OPEN2", None) )
    1.17 +    else:
    1.18 +        sys.stderr.write("WARNING: older version of e2fsprogs installed, not building full\n")
    1.19 +        sys.stderr.write("         disk support for ext2.\n")
    1.20          
    1.21      ext2 = Extension("grub.fsys.ext2._pyext2",
    1.22                       extra_compile_args = extra_compile_args,