ia64/xen-unstable

changeset 5777:1fb47826d767

Misc fixes for new sparse tree names: xen-clone script; -xen kernel build (the one with all the modules); Backout changes to legacy targets.

Signed-off-by: ian.pratt@cl.cam.ac.uk
author iap10@freefall.cl.cam.ac.uk
date Thu Jul 14 10:12:51 2005 +0000 (2005-07-14)
parents 64f26eed8d47
children 43c21adcfc79
files Makefile buildconfigs/mk.linux-2.6-xen tools/misc/xen-clone
line diff
     1.1 --- a/Makefile	Thu Jul 14 09:05:22 2005 +0000
     1.2 +++ b/Makefile	Thu Jul 14 10:12:51 2005 +0000
     1.3 @@ -181,10 +181,10 @@ uninstall:
     1.4  
     1.5  # Legacy targets for compatibility
     1.6  linux24:
     1.7 -	$(MAKE) 'KERNELS=linux-2.4-xen0 linux-2.4-xenU' kernels
     1.8 +	$(MAKE) 'KERNELS=linux-2.4*' kernels
     1.9  
    1.10  linux26:
    1.11 -	$(MAKE) 'KERNELS=linux-2.6-xen0 linux-2.6-xenU' kernels
    1.12 +	$(MAKE) 'KERNELS=linux-2.6*' kernels
    1.13  
    1.14  netbsd20:
    1.15  	$(MAKE) netbsd-2.0-xenU-build
     2.1 --- a/buildconfigs/mk.linux-2.6-xen	Thu Jul 14 09:05:22 2005 +0000
     2.2 +++ b/buildconfigs/mk.linux-2.6-xen	Thu Jul 14 10:12:51 2005 +0000
     2.3 @@ -2,6 +2,7 @@
     2.4  OS           = linux
     2.5  
     2.6  LINUX_SERIES = 2.6
     2.7 +LINUX_VER    = 2.6.12
     2.8  
     2.9  EXTRAVERSION = xen
    2.10  
    2.11 @@ -23,7 +24,7 @@ build: $(LINUX_DIR)/include/linux/autoco
    2.12  	rm -rf $(LINUX_DIR)
    2.13  	cp -al $(<D) $(LINUX_DIR)
    2.14  	# Apply arch-xen patches
    2.15 -	( cd linux-$(LINUX_VER)-xen-sparse ; \
    2.16 +	( cd linux-$(LINUX_SERIES)-xen-sparse ; \
    2.17            ./mkbuildtree ../$(LINUX_DIR) )
    2.18  	# Re-use config from install dir if one exits else use default config
    2.19  	CONFIG_VERSION=$$(sed -ne 's/^EXTRAVERSION = //p' $(LINUX_DIR)/Makefile); \
     3.1 --- a/tools/misc/xen-clone	Thu Jul 14 09:05:22 2005 +0000
     3.2 +++ b/tools/misc/xen-clone	Thu Jul 14 10:12:51 2005 +0000
     3.3 @@ -60,7 +60,7 @@ cd ${TOP}
     3.4  fi
     3.5  
     3.6  
     3.7 -if [ -d ${DEST_BK_REP}/linux-2.4.*-xen-sparse ]
     3.8 +if [ -d ${DEST_BK_REP}/linux-2.4*-xen-sparse ]
     3.9  then
    3.10   # this is a new style Xen repository so building is dead easy
    3.11