ia64/xen-unstable

view docs/check_pkgs @ 4107:fcd17066e110

bitkeeper revision 1.1159.270.1 (423308766_Mxiqyj1XF-m4OxnLnExA)

No longer require latex2html (bizarrely considered 'non-free' by Debian
maintainers) to build docs. Instead we still build PS/PDF docs, but skip
HTML docs.
Signed-off-by: Keir Fraser <keir.fraser@cl.cam.ac.uk>
author kaf24@viper.(none)
date Sat Mar 12 15:19:18 2005 +0000 (2005-03-12)
parents 9340287b7f30
children a0be5e5a1f37 508b288d20e2
line source
2 silent_which ()
3 {
4 if ! `which $1 1>/dev/null 2>/dev/null`; then
5 echo "*************************************************"
6 echo "*************************************************"
7 echo "* WARNING: Package '$1' is required"
8 echo "* to build Xen documentation"
9 echo "*************************************************"
10 echo "*************************************************"
11 fi
12 which $1 1>/dev/null 2>/dev/null
13 }
15 silent_which latex || exit 1
16 silent_which dvips || exit 1
17 silent_which ps2pdf || exit 1
18 silent_which fig2dev || exit 1
20 exit 0