ia64/xen-unstable

view docs/check_pkgs @ 4750:efa6730ad90e

bitkeeper revision 1.1159.258.112 (4277a730mvnFSFXrxJpVRNk8hjD4Vg)

[PATCH] Mkbuildtree little fix

Hi, here is a really small fix for mkbuildtree.

With my 'find' version [1], I get many of these warning when using mkbuildtree:

find: warning: you have specified the -maxdepth option after a
non-option argument -type, but options are not positional (-maxdepth
affects tests specified before it as well as those specified after it).
Please specify options before other arguments.

My patch just correct the ordering of the options, it should be
harmless, but I didn't test with other versions of find.

Regards

[1] find --version
GNU find version 4.2.20
Features enabled: D_TYPE O_NOFOLLOW(enabled)

xen-unstable-mkbuildtree-find-maxpath.patch:
author ydroneaud@mandriva.com[kaf24]
date Tue May 03 16:30:40 2005 +0000 (2005-05-03)
parents a0be5e5a1f37
children 0dc3b8b8c298
line source
2 silent_which ()
3 {
4 if ! `which $1 1>/dev/null 2>/dev/null`; then
5 echo "*************************************************"
6 echo "*************************************************"
7 echo "* WARNING: Package '$1' is required"
8 echo "* to build Xen documentation"
9 echo "*************************************************"
10 echo "*************************************************"
11 fi
12 which $1 1>/dev/null 2>/dev/null
13 }
15 silent_which latex || exit 1
16 silent_which dvips || exit 1
17 silent_which ps2pdf || exit 1
18 silent_which fig2dev || exit 1
20 exit 0