ia64/xen-unstable

view unmodified_drivers/linux-2.6/overrides.mk @ 17629:9be45076186d

ia64 pv-on-hvm: __XEN_INTERFACE_VERSION__ is needed to assemble
platform-pci/xcom_asm.S, otherwise incompatible kernel module is
built.

Signed-off-by: Kouya Shimura <kouya@jp.fujitsu.com>
author Keir Fraser <keir.fraser@citrix.com>
date Mon May 12 10:14:01 2008 +0100 (2008-05-12)
parents 700f33cc0297
children 11d12d61b138
line source
1 # Hack: we need to use the config which was used to build the kernel,
2 # except that that won't have the right headers etc., so duplicate
3 # some of the mach-xen infrastructure in here.
4 #
5 # (i.e. we need the native config for things like -mregparm, but
6 # a Xen kernel to find the right headers)
7 _XEN_CPPFLAGS += -D__XEN_INTERFACE_VERSION__=0x00030205
8 _XEN_CPPFLAGS += -DCONFIG_XEN_COMPAT=0xffffff
9 _XEN_CPPFLAGS += -I$(M)/include -I$(M)/compat-include -DHAVE_XEN_PLATFORM_COMPAT_H
10 ifeq ($(ARCH),ia64)
11 _XEN_CPPFLAGS += -DCONFIG_VMX_GUEST
12 endif
14 _XEN_CPPFLAGS += -include $(objtree)/include/linux/autoconf.h
16 EXTRA_CFLAGS += $(_XEN_CPPFLAGS)
17 EXTRA_AFLAGS += $(_XEN_CPPFLAGS)