ia64/xen-unstable

view tools/check/check_hotplug @ 7264:409cea2432fc

Add installation of the udev rules if appropriate. With a normal 'make
install', the udev rules will be installed if udev version is >= 059;
otherwise, the hotplug rules get installed.

When 'make dist' is done, we set a variable so that both hotplug and
udev rules are installed into the dist tarball. install.sh then takes
care of picking the proper rules.

Also changes the hotplug check to look for a proper udev version

Signed-off-by: Jeremy Katz <katzj@redhat.com>
author kaf24@firebug.cl.cam.ac.uk
date Fri Oct 07 14:47:45 2005 +0100 (2005-10-07)
parents ef9591d03fdd
children 4e0c94871be2
line source
1 #!/bin/bash
2 # CHECK-INSTALL
4 function error {
5 echo
6 echo ' *** Check for the hotplug scripts (hotplug) FAILED'
7 exit 1
8 }
10 if [ -x /sbin/udev ] && [ ! -z `udev -V` ] && [ `udev -V` -ge 059 ]; then
11 exit 0
12 fi
14 which hotplug 1>/dev/null 2>&1 || error