ia64/xen-unstable

view docs/check_pkgs @ 16242:3d97c1c1f7c8

pv-on-hvm: fixes for unmodified drivers build and modern Linux

- The adjustments to README and overrides.mk are generic.
- The removal of explicit linux/config.h inclusion should also not
cause any issues.
- The introduction of irq_handler_t should eliminiate warnings on
2.6.19+ kernels (I didn't check they're there, but since the
request_irq prototype changed, I'm sure there's at least
one. However, as a result changes to the Linux tree are expected to
be required.
- The change setup_xen_features -> xen_setup_features follows the
naming in mainline 2.6.23 but would apparently also require changes
to the Linux tree.
- The changes SA_* -> IRQF_ and pci_module_init ->
pci_register_driver should also not cause issues.

Signed-off-by: Jan Beulich <jbeulich@novell.com>
author Keir Fraser <keir@xensource.com>
date Thu Oct 25 15:54:19 2007 +0100 (2007-10-25)
parents cf0c13832905
children 59d511c4a8d8
line source
2 silent_which ()
3 {
4 which $1 1>/dev/null 2>/dev/null || {
5 echo "*************************************************"
6 echo "*************************************************"
7 echo "* WARNING: Package '$1' is required"
8 echo "* to build Xen documentation"
9 echo "*************************************************"
10 echo "*************************************************"
11 }
12 which $1 1>/dev/null 2>/dev/null
13 }
15 silent_which latex || exit 1
16 silent_which dvips || exit 1
17 silent_which ps2pdf || exit 1
18 silent_which fig2dev || exit 1
20 exit 0