ia64/xen-unstable

view install.sh @ 8697:11ed48af31d7

Ever since patchset 8648 (xen-unstable.hg) all my configuration files
fail with the following:

Error: Device 768 (vbd) could not be connected. Hotplug scripts not working.

(Since my HVM tree follows xen-unstable.hg closely, it breaks too).

The following patch undoes a small part of Ke Yu's patch and fixes the
problem.

However, I'm having trouble understanding what this part did in the
original patch. Was there a subtle change in the disk variable format
that I missed?

Signed-Off-By: Leendert van Doorn <leendert@watson.ibm.com>
author kaf24@firebug.cl.cam.ac.uk
date Sun Jan 29 10:52:43 2006 +0100 (2006-01-29)
parents 5ae89ce67486
children e639d53330ba
line source
1 #!/bin/sh
3 src='./install'
4 if [ -d ./dist ]; then
5 src='./dist/install'
6 fi
8 if ! [ -d $src ]; then
9 echo "ERROR: Could not find a valid distribution directory."
10 echo " If this is a source-only release, try 'make dist'."
11 exit 1
12 fi
14 dst='/'
15 if [ $# -ne 0 ]; then
16 dst=$1
17 fi
19 if ! [ -d $dst ]; then
20 echo "ERROR: You must specify a valid install directory."
21 echo " The specified directory '$dst' is not valid."
22 exit 1
23 fi
25 echo "Installing Xen from '$src' to '$dst'..."
26 (cd $src; tar -cf - --exclude etc/init.d --exclude etc/hotplug --exclude etc/udev * ) | tar -C $dst -xf -
27 cp -fdRL $src/etc/init.d/* $dst/etc/init.d/
28 echo "All done."
30 [ -x "$(which udevinfo)" ] && \
31 UDEV_VERSION=$(udevinfo -V | sed -e 's/^[^0-9]* \([0-9]\{1,\}\)[^0-9]\{0,\}/\1/')
33 if [ -n "$UDEV_VERSION" ] && [ $UDEV_VERSION -ge 059 ]; then
34 cp -f $src/etc/udev/rules.d/*.rules $dst/etc/udev/rules.d/
35 else
36 cp -f $src/etc/hotplug/*.agent $dst/etc/hotplug/
37 fi
39 echo "Checking to see whether prerequisite tools are installed..."
40 cd $src/../check
41 ./chk install
42 echo "All done."
44 exit 0