ia64/xen-unstable

annotate docs/check_pkgs @ 6191:430ce2bade9b

Trivial fixes for a couple of xenlinux compile warnings.

Signed-off-by: <andrew.warfield@cl.cam.ac.uk>
author akw27@arcadians.cl.cam.ac.uk
date Mon Aug 15 13:50:39 2005 +0000 (2005-08-15)
parents a01199a95070
children cf0c13832905
rev   line source
kaf24@2826 1
kaf24@2826 2 silent_which ()
kaf24@2826 3 {
kaf24@2826 4 if ! `which $1 1>/dev/null 2>/dev/null`; then
kaf24@2826 5 echo "*************************************************"
kaf24@2826 6 echo "*************************************************"
kaf24@2826 7 echo "* WARNING: Package '$1' is required"
kaf24@2826 8 echo "* to build Xen documentation"
kaf24@2826 9 echo "*************************************************"
kaf24@2826 10 echo "*************************************************"
kaf24@2826 11 fi
kaf24@2826 12 which $1 1>/dev/null 2>/dev/null
kaf24@2826 13 }
kaf24@2826 14
kaf24@2826 15 silent_which latex || exit 1
kaf24@2826 16 silent_which dvips || exit 1
kaf24@2826 17 silent_which ps2pdf || exit 1
kaf24@2826 18 silent_which fig2dev || exit 1
kaf24@2826 19
kaf24@2826 20 exit 0