direct-io.hg

changeset 7946:44d96609ea71

Added document to collate information regarding distro-specific
incompatibilities in the commands that we are using in the scripts.

Signed-off-by: Ewan Mellor <ewan@xensource.com>
author emellor@leeni.uk.xensource.com
date Sun Nov 20 15:40:53 2005 +0100 (2005-11-20)
parents 83bc047bb346
children 27a2cb379c8f
files tools/examples/README.incompatibilities
line diff
     1.1 --- /dev/null	Thu Jan 01 00:00:00 1970 +0000
     1.2 +++ b/tools/examples/README.incompatibilities	Sun Nov 20 15:40:53 2005 +0100
     1.3 @@ -0,0 +1,25 @@
     1.4 +Command Incompatibilities
     1.5 +=========================
     1.6 +
     1.7 +Known incompatibilities with various commands on various distributions, and
     1.8 +the workarounds we use.
     1.9 +
    1.10 +
    1.11 +brctl
    1.12 +-----
    1.13 +
    1.14 +brctl show <bridge> fails on SLES9 SP2.  Workaround is to use brctl show
    1.15 +without arguments, and grep, though this would be difficult were you to need
    1.16 +to check for a specific bridge-interface pair, since brctl does not show the 
    1.17 +bridge name on every line.
    1.18 +
    1.19 +
    1.20 +ifup / ifdown
    1.21 +-------------
    1.22 +
    1.23 +SuSE requires an extra parameter to ifup, which is created by calling getcfg
    1.24 +appropriately.  See xen-network-common.sh for details.
    1.25 +
    1.26 +Gentoo doesn't have ifup/ifdown; appropriate alternatives are defined in
    1.27 +xen-network-common.sh.
    1.28 +